BLACK Idle ignition stays active


Idle ignition stays active even after it says, that idle is not active. And those idle ignition values subtracts from main ignition table.
How can we fix it?
More over, sometimes if the engine and ecu restarts it goes to normal operation. If idle is not active then 0 deg is shown.
This unstable charasteritics can hurt the engine.

This setup is in EJ20 rally car, so getting all the time -7 deg of timing from main table heats up the engine.

what firmware are you using?

Can you post the entire log file and calibration?

is it pulling 7 degrees from the table value? I see the number staying at -7 when the rpm is above idle rpm target but is it actually taking it out of the base table value?
Have you tried using the idle ignition correction table instead?

Nope, I didn’t tried the correction table…
Its pulling 7 degrees overall.
I have -2.5 on IAT which pulls out from overall timing and also this -7 degrees of timing.
So overall It puls out -9.5 deg of timing.
If the table has 16deg BTDC at max torque, it pulls out that -9.5 deg and whats left is nothing…
I’ve attached log and map.
Map needs to be adjusted acordinaly over time after the race. So You could find some intresting places…

EDL files kind a huge, so I’ve puted in drive

Tell me if You can download it

lambda guard and IAT is correcting igniton

Good point. I will check it.

I’m sure I found the bug.
In the config i have table switch, which enebales second VE,AFR and IGN tables.

Problem: if You use table switch. It switches something also in the IDLE settings. And leaves ignition correction always active.
If table switch is not used, then Idle ignition correction is not active. And behaves only while status of idle control is active.

Where I can register the bug?