Pro8 13B Trigger issue


I have a client with 13B engine and EmuPro8 inside.
Everything works well, but I can’t find why I have no RPM readings.

Trigger we are using is stock CAS.
24 tooth - main signal.
2 tooth - home signal.

Maybe someone has already implemented something with it in emupro?

Later on I will upload config, log, and trigger log.

Thank You

rx_scope_idling.emuproscp (2.9 KB)
rx7 13B starting idling.emupro (22.8 KB)
rx7 13B starting idling.emuprolog (592.0 KB)

The method I used to find TDC I found in this video:


I’m still struggling.
Did everything last night. But still no RPM on crank. And no sync…
I disable the injectors, because I dont want the engine to fire up. I want to find the rpm on the cranking. But still getting 0 RPM and no sync.
I’ve tried all the angles, from 0 to 420, still nothing.
Attached the files… What can be wrong? Maybe distributor is faulty?
Or I should switch to external 36-1 disc on pulley?

I attached via google drive, I cant upload here directly :frowning: new user…

This is odd. Trigger scope looks good and correct, but the log file is indicating “not synchronized”…

Wild idea, but try putting it into a different engine mode and see if it achieves sync. Don’t attempt to start it like that obviously.
I can’t see anything wrong in your trigger settings or engine settings and the log isn’t showing any spark cuts or executed sparks.
First TDC angle doesn’t matter until its synchronizing and delivering spark

Good Morning,

Please downgrade the firmware to the 102 version and try to do a scope and log file one more time.

Thank you all for the support.
Trigger works fine now and i see synced status.

I’ve upgraded the FW to 103.1
And configured all injectors, ignition and etc.
Only disconected the FP fuse, because I don’t want it to start yet the engine.

I assume that EmuPro doesn’t like if injectors are not configured. Previously I disabled all injectors channels and that cause an issue.

If anyone needs log, triggers and configs. You can take it from the drive link.

Case closed! Thank You!

1 Like


Not assigned injectors shouldn’t be an issue with RPM calculation, this is odd.
But this is great news, that the problem is solved.

1 Like