USB logging issue

Hello guys,

I have had my Pro8 up and running for over a month now, and i love it.

I have one issue that i cant get to work and thats the USB logger.

I have double checked the wiring twice now and it is definetly correct as per the diagram supplied with the emu.

I have tried multiple usb sticks and the problem remains. these have always been fresh formatted to FAT32 and are 2 & 8GB nothing bigger

I have attached a picture of my issue.

Any help with this would be appreciated.


Anyone help with this?

Having the laptop beside me all the time for logging is getting annoying.


What brand/model of flashdrive are you using?

We are recommending SANDISK USB 3.0 flashdrives. These are cheap and reliable.
Flashdrives of up to 32 GB are pre-formatted with FAT32.

MemoryNotReady means that the EMU PRO can somehow communicate over the USB, but the flashdrive “Mass Storage Device” protocol is not responding.

I have checked my SanDisk 32GB flash drive on ADU (should work in the same way) and with proper wiring while plugging the status changes:
Disconnected - AccesingUSB - Saving

With exchanged digital pins:
Disconnected - AccessingUSB - Disconnected (stable, not changing again)

It is not easy to figure out as there could be many possible reasons.

  1. What models of USB sticks do you use?
  2. Does it work when engine is turned off?
  3. Did you connect USB cable shield to GND?
  4. Could you provide a log file with channels under “Logger” section logged with at least 100Hz when you connect the USB stick?

ill be honest it has been cheap 8gb flash drives i have been using.

I will order a USB 3.0 sandisk and report back.


Hi guys,

Sorted now, changed all the usb logger wiring and it has solved my issue.

Wether it was a broken wire withing my harness or just getting interferance im not sure.

1 Like